Related Products
DINSTAR C60U/C60UP ENTRY LEVEL IP PHONE WITH ADAPTER
DINSTAR C60U-W Wi-Fi IP Phone with POE & Without Adapter
Dinstar DAG1000-4S FXS Analog VoIP Gateway
DINSTAR C60SP ENTRY LEVEL IP PHONE WITHOUT ADAPTER
UGREEN X688 Uno 100W 4-Port GaN Fast Charger - US
DINSTAR C63GP COLOR SCREEN IP PHONE with POE & Without Adapter
DINSTAR C60S ENTRY LEVEL IP PHONE
DINSTAR UC200 Pro 500 SIP IP PBX System
DINSTAR C62U/C62UP COLOR SCREEN IP PHONE WITHOUT ADAPTER
DINSTAR C63G COLOR SCREEN IP PHONE With POE & With Adapter
No image
No image
DINSTAR C62UP ENTRY LEVEL IP PHONE with POE & With Adapter
- HD Voice
- 2 Extension accounts
- 132x64 pixel Graphical LCD
- Dual‐port 10/100Mbps Ethernet
Product Pricing
EMI Start From*
SPECIFICATIONS
Display
Networking & Connectivity
SIP over TLS, SRTP
TCP/ IP/ UDP & LLDP
RTP/ RTCP, RFC2198, RFC1889
HTTP/ HTTPS/ FTP/ TFTP
ARP/ RARP/ ICMP/ NTP/ DHCP
DNS SRV/ A Query/ NATPR Query
STUN, Session timer (RFC4028)
DTMF: In-Band, RFC2833, SIP INFO
OpenVPN, 802.1X
Audio & Microphone
Battery And Power
IP Phone
Physical Specification
Technical Info
Warranty Information
DESCRIPTION
DINSTAR C62UP ENTRY-LEVEL IP PHONE in Bangladesh
The Dinstar C62UP is a professional IP phone designed for reliable business communication and modern VoIP environments. It features a 2.4-inch color display with a 320 × 240 resolution, HD voice quality, full-duplex hands-free communication, and support for multiple audio codecs.
The phone supports SIP v1 and SIP v2 protocols, SIP over TLS, SRTP encryption, IPv4/IPv6-ready network features, OpenVPN, 802.1X authentication, LLDP, STUN, NAT traversal, and a wide range of network and call management protocols. It also supports 5-way conference calling, call waiting with caller ID, call logs, auto answer, call hold, call transfer, and redial functions.
With PoE support and a 5V DC power adapter option, the Dinstar C62UP is suitable for offices, call centers, reception desks, hotels, educational institutions, and other professional communication setups.
The Dinstar C62UP combines clear HD audio, advanced VoIP features, strong network compatibility, and flexible power options in a compact and professional design. TechLand BD sells this product.
REVIEWS
Login to write a review.
No reviews yet
Be the first to share your thoughts about this product.
Write a Review
What is the DINSTAR C62UP ENTRY LEVEL IP PHONE with POE & With Adapter Price in Bangladesh 2026 ?
Related Products
DINSTAR C60U/C60UP ENTRY LEVEL IP PHONE WITH ADAPTER
DINSTAR C60U-W Wi-Fi IP Phone with POE & Without Adapter
Dinstar DAG1000-4S FXS Analog VoIP Gateway
DINSTAR C60SP ENTRY LEVEL IP PHONE WITHOUT ADAPTER
UGREEN X688 Uno 100W 4-Port GaN Fast Charger - US
DINSTAR C63GP COLOR SCREEN IP PHONE with POE & Without Adapter
DINSTAR C60S ENTRY LEVEL IP PHONE
DINSTAR UC200 Pro 500 SIP IP PBX System
DINSTAR C62U/C62UP COLOR SCREEN IP PHONE WITHOUT ADAPTER
DINSTAR C63G COLOR SCREEN IP PHONE With POE & With Adapter
EMI Calculator
| Month | Charges | Installment | Overall Cost |
|---|---|---|---|
| 3 | ৳270 | ৳1,823 | ৳5,470 |
| 6 | ৳356 | ৳926 | ৳5,556 |
| 9 | ৳475 | ৳631 | ৳5,675 |
| 12 | ৳599 | ৳483 | ৳5,799 |
| Month | Charges | Installment | Overall Cost |
|---|---|---|---|
| 3 | ৳270 | ৳1,823 | ৳5,470 |
| 6 | ৳356 | ৳926 | ৳5,556 |
| 9 | ৳475 | ৳631 | ৳5,675 |
| 12 | ৳599 | ৳483 | ৳5,799 |
| 18 | ৳796 | ৳333 | ৳5,996 |
| 24 | ৳1,080 | ৳262 | ৳6,280 |
| 30 | ৳1,155 | ৳212 | ৳6,355 |
| 36 | ৳1,392 | ৳183 | ৳6,592 |
| Month | Charges | Installment | Overall Cost |
|---|---|---|---|
| 3 | ৳270 | ৳1,823 | ৳5,470 |
| 6 | ৳356 | ৳926 | ৳5,556 |
| 9 | ৳475 | ৳631 | ৳5,675 |
| 12 | ৳599 | ৳483 | ৳5,799 |
| Month | Charges | Installment | Overall Cost |
|---|---|---|---|
| 3 | ৳270 | ৳1,823 | ৳5,470 |
| 6 | ৳356 | ৳926 | ৳5,556 |
| 9 | ৳475 | ৳631 | ৳5,675 |
| 12 | ৳599 | ৳483 | ৳5,799 |
| 18 | ৳796 | ৳333 | ৳5,996 |
| 24 | ৳1,080 | ৳262 | ৳6,280 |
| Month | Charges | Installment | Overall Cost |
|---|---|---|---|
| 3 | ৳327 | ৳1,842 | ৳5,527 |
| 6 | ৳414 | ৳936 | ৳5,614 |
| 9 | ৳534 | ৳637 | ৳5,734 |
| 12 | ৳659 | ৳488 | ৳5,859 |
| 18 | ৳857 | ৳337 | ৳6,057 |
| 24 | ৳1,145 | ৳264 | ৳6,345 |
| 30 | ৳1,220 | ৳214 | ৳6,420 |
| 36 | ৳1,460 | ৳185 | ৳6,660 |
| Month | Charges | Installment | Overall Cost |
|---|---|---|---|
| 3 | ৳270 | ৳1,823 | ৳5,470 |
| 6 | ৳356 | ৳926 | ৳5,556 |
| 9 | ৳475 | ৳631 | ৳5,675 |
| 12 | ৳599 | ৳483 | ৳5,799 |
| Month | Charges | Installment | Overall Cost |
|---|---|---|---|
| 3 | ৳270 | ৳1,823 | ৳5,470 |
| 6 | ৳356 | ৳926 | ৳5,556 |
| 9 | ৳475 | ৳631 | ৳5,675 |
| 12 | ৳599 | ৳483 | ৳5,799 |
| 18 | ৳796 | ৳333 | ৳5,996 |
| 24 | ৳1,080 | ৳262 | ৳6,280 |
| 30 | ৳1,155 | ৳212 | ৳6,355 |
| 36 | ৳1,392 | ৳183 | ৳6,592 |
| Month | Charges | Installment | Overall Cost |
|---|---|---|---|
| 3 | ৳270 | ৳1,823 | ৳5,470 |
| 6 | ৳356 | ৳926 | ৳5,556 |
| 9 | ৳475 | ৳631 | ৳5,675 |
| 12 | ৳599 | ৳483 | ৳5,799 |
| 18 | ৳796 | ৳333 | ৳5,996 |
| 24 | ৳1,080 | ৳262 | ৳6,280 |
| 30 | ৳1,155 | ৳212 | ৳6,355 |
| 36 | ৳1,392 | ৳183 | ৳6,592 |
| Month | Charges | Installment | Overall Cost |
|---|---|---|---|
| 3 | ৳270 | ৳1,823 | ৳5,470 |
| 6 | ৳356 | ৳926 | ৳5,556 |
| 9 | ৳475 | ৳631 | ৳5,675 |
| 12 | ৳599 | ৳483 | ৳5,799 |
| 18 | ৳796 | ৳333 | ৳5,996 |
| 24 | ৳1,080 | ৳262 | ৳6,280 |
| 30 | ৳1,155 | ৳212 | ৳6,355 |
| 36 | ৳1,392 | ৳183 | ৳6,592 |
| Month | Charges | Installment | Overall Cost |
|---|---|---|---|
| 3 | ৳270 | ৳1,823 | ৳5,470 |
| 6 | ৳356 | ৳926 | ৳5,556 |
| 9 | ৳475 | ৳631 | ৳5,675 |
| 12 | ৳599 | ৳483 | ৳5,799 |
| 18 | ৳796 | ৳333 | ৳5,996 |
| 24 | ৳1,080 | ৳262 | ৳6,280 |
| Month | Charges | Installment | Overall Cost |
|---|---|---|---|
| 3 | ৳270 | ৳1,823 | ৳5,470 |
| 6 | ৳356 | ৳926 | ৳5,556 |
| 9 | ৳475 | ৳631 | ৳5,675 |
| 12 | ৳599 | ৳483 | ৳5,799 |
| 18 | ৳796 | ৳333 | ৳5,996 |
| 24 | ৳1,080 | ৳262 | ৳6,280 |
| 30 | ৳1,155 | ৳212 | ৳6,355 |
| 36 | ৳1,392 | ৳183 | ৳6,592 |
| Month | Charges | Installment | Overall Cost |
|---|---|---|---|
| 3 | ৳270 | ৳1,823 | ৳5,470 |
| 6 | ৳356 | ৳926 | ৳5,556 |
| 9 | ৳475 | ৳631 | ৳5,675 |
| 12 | ৳599 | ৳483 | ৳5,799 |
| 18 | ৳796 | ৳333 | ৳5,996 |
| 24 | ৳1,080 | ৳262 | ৳6,280 |
| 30 | ৳1,155 | ৳212 | ৳6,355 |
| 36 | ৳1,392 | ৳183 | ৳6,592 |
| Month | Charges | Installment | Overall Cost |
|---|---|---|---|
| 3 | ৳270 | ৳1,823 | ৳5,470 |
| 6 | ৳356 | ৳926 | ৳5,556 |
| 9 | ৳475 | ৳631 | ৳5,675 |
| 12 | ৳599 | ৳483 | ৳5,799 |
| 18 | ৳796 | ৳333 | ৳5,996 |
| 24 | ৳1,080 | ৳262 | ৳6,280 |
| 30 | ৳1,155 | ৳212 | ৳6,355 |
| 36 | ৳1,392 | ৳183 | ৳6,592 |
| Month | Charges | Installment | Overall Cost |
|---|---|---|---|
| 3 | ৳270 | ৳1,823 | ৳5,470 |
| 6 | ৳356 | ৳926 | ৳5,556 |
| 9 | ৳475 | ৳631 | ৳5,675 |
| 12 | ৳599 | ৳483 | ৳5,799 |
| Month | Charges | Installment | Overall Cost |
|---|---|---|---|
| 3 | ৳270 | ৳1,823 | ৳5,470 |
| 6 | ৳356 | ৳926 | ৳5,556 |
| 9 | ৳475 | ৳631 | ৳5,675 |
| 12 | ৳599 | ৳483 | ৳5,799 |
| 18 | ৳796 | ৳333 | ৳5,996 |
| 24 | ৳1,080 | ৳262 | ৳6,280 |
| 30 | ৳1,155 | ৳212 | ৳6,355 |
| 36 | ৳1,392 | ৳183 | ৳6,592 |
| Month | Charges | Installment | Overall Cost |
|---|---|---|---|
| 3 | ৳270 | ৳1,823 | ৳5,470 |
| 6 | ৳356 | ৳926 | ৳5,556 |
| 9 | ৳475 | ৳631 | ৳5,675 |
| 12 | ৳599 | ৳483 | ৳5,799 |
| 18 | ৳796 | ৳333 | ৳5,996 |
| 24 | ৳1,080 | ৳262 | ৳6,280 |
| Month | Charges | Installment | Overall Cost |
|---|---|---|---|
| 3 | ৳299 | ৳1,833 | ৳5,499 |
| 6 | ৳415 | ৳936 | ৳5,615 |
| 9 | ৳568 | ৳641 | ৳5,768 |
| 12 | ৳729 | ৳494 | ৳5,929 |
| 18 | ৳934 | ৳341 | ৳6,134 |
| 24 | ৳1,232 | ৳268 | ৳6,432 |
| 36 | ৳1,647 | ৳190 | ৳6,847 |
| Month | Charges | Installment | Overall Cost |
|---|---|---|---|
| 3 | ৳270 | ৳1,823 | ৳5,470 |
| 6 | ৳356 | ৳926 | ৳5,556 |
| 9 | ৳475 | ৳631 | ৳5,675 |
| 12 | ৳599 | ৳483 | ৳5,799 |
| 18 | ৳796 | ৳333 | ৳5,996 |
| 24 | ৳1,080 | ৳262 | ৳6,280 |
| Month | Charges | Installment | Overall Cost |
|---|---|---|---|
| 3 | ৳270 | ৳1,823 | ৳5,470 |
| 6 | ৳356 | ৳926 | ৳5,556 |
| 9 | ৳475 | ৳631 | ৳5,675 |
| 12 | ৳599 | ৳483 | ৳5,799 |
| Month | Charges | Installment | Overall Cost |
|---|---|---|---|
| 3 | ৳270 | ৳1,823 | ৳5,470 |
| 6 | ৳356 | ৳926 | ৳5,556 |
| 9 | ৳475 | ৳631 | ৳5,675 |
| 12 | ৳599 | ৳483 | ৳5,799 |
| 18 | ৳796 | ৳333 | ৳5,996 |
| 24 | ৳1,080 | ৳262 | ৳6,280 |
| Month | Charges | Installment | Overall Cost |
|---|---|---|---|
| 3 | ৳270 | ৳1,823 | ৳5,470 |
| 6 | ৳356 | ৳926 | ৳5,556 |
| 9 | ৳475 | ৳631 | ৳5,675 |
| 12 | ৳599 | ৳483 | ৳5,799 |
| 18 | ৳796 | ৳333 | ৳5,996 |
| 24 | ৳1,080 | ৳262 | ৳6,280 |
| Month | Charges | Installment | Overall Cost |
|---|---|---|---|
| 3 | ৳270 | ৳1,823 | ৳5,470 |
| 6 | ৳356 | ৳926 | ৳5,556 |
| 9 | ৳475 | ৳631 | ৳5,675 |
| 12 | ৳599 | ৳483 | ৳5,799 |
| 18 | ৳796 | ৳333 | ৳5,996 |
| 24 | ৳1,080 | ৳262 | ৳6,280 |
| Month | Charges | Installment | Overall Cost |
|---|---|---|---|
| 3 | ৳270 | ৳1,823 | ৳5,470 |
| 6 | ৳356 | ৳926 | ৳5,556 |
| 9 | ৳475 | ৳631 | ৳5,675 |
| 12 | ৳599 | ৳483 | ৳5,799 |
| Month | Charges | Installment | Overall Cost |
|---|---|---|---|
| 3 | ৳270 | ৳1,823 | ৳5,470 |
| 6 | ৳356 | ৳926 | ৳5,556 |
| 9 | ৳475 | ৳631 | ৳5,675 |
| 12 | ৳599 | ৳483 | ৳5,799 |
| 18 | ৳796 | ৳333 | ৳5,996 |
| 24 | ৳1,080 | ৳262 | ৳6,280 |
| Month | Charges | Installment | Overall Cost |
|---|---|---|---|
| 3 | ৳270 | ৳1,823 | ৳5,470 |
| 6 | ৳356 | ৳926 | ৳5,556 |
| 9 | ৳475 | ৳631 | ৳5,675 |
| 12 | ৳599 | ৳483 | ৳5,799 |
| 18 | ৳796 | ৳333 | ৳5,996 |
| 24 | ৳1,080 | ৳262 | ৳6,280 |
| Month | Charges | Installment | Overall Cost |
|---|---|---|---|
| 3 | ৳270 | ৳1,823 | ৳5,470 |
| 6 | ৳356 | ৳926 | ৳5,556 |
| 9 | ৳475 | ৳631 | ৳5,675 |
| 12 | ৳599 | ৳483 | ৳5,799 |
| 18 | ৳796 | ৳333 | ৳5,996 |
| 24 | ৳1,080 | ৳262 | ৳6,280 |
| 30 | ৳1,155 | ৳212 | ৳6,355 |
| 36 | ৳1,392 | ৳183 | ৳6,592 |
| Month | Charges | Installment | Overall Cost |
|---|---|---|---|
| 3 | ৳270 | ৳1,823 | ৳5,470 |
| 6 | ৳356 | ৳926 | ৳5,556 |
| 9 | ৳475 | ৳631 | ৳5,675 |
| 12 | ৳599 | ৳483 | ৳5,799 |
| Month | Charges | Installment | Overall Cost |
|---|---|---|---|
| 3 | ৳270 | ৳1,823 | ৳5,470 |
| 6 | ৳356 | ৳926 | ৳5,556 |
| 9 | ৳475 | ৳631 | ৳5,675 |
| 12 | ৳599 | ৳483 | ৳5,799 |
| 18 | ৳796 | ৳333 | ৳5,996 |
| 24 | ৳1,080 | ৳262 | ৳6,280 |
| 30 | ৳1,155 | ৳212 | ৳6,355 |
| 36 | ৳1,392 | ৳183 | ৳6,592 |
| Month | Charges | Installment | Overall Cost |
|---|---|---|---|
| 3 | ৳270 | ৳1,823 | ৳5,470 |
| 6 | ৳356 | ৳926 | ৳5,556 |
| 9 | ৳475 | ৳631 | ৳5,675 |
| 12 | ৳599 | ৳483 | ৳5,799 |
| 18 | ৳796 | ৳333 | ৳5,996 |
| 24 | ৳1,080 | ৳262 | ৳6,280 |
| 30 | ৳1,155 | ৳212 | ৳6,355 |
| 36 | ৳1,392 | ৳183 | ৳6,592 |
Product Disclaimer
- Stock Availability Is Subject To Change. Please Confirm Availability Before Shopping By Calling Us.
- The Product Image Is For Illustration Purposes Only. The Actual Product May Vary In Size, Color, And Layout. No Claim Will Be Accepted For An Image Mismatch.
- Tech Land BD Can Change The Price Of Any Product At Any Moment Due To The Volatile Price Of The Technology.
- We Cannot Guarantee That The Information On This Page Is 100% Correct. Tech Land BD Is Not Responsible For The Results Obtained From The Use Of This Information.
Give your Suggestion
Don't have an account ? Register